Support forums : Feature Requests

Blog settings for twitter plugin

Now that you've read stuff first and introduced yourself, the next thing you'll probably want to do is say what you want Quam Plures to have and do. So here ya go: A feature request forum!

Moderator: Dracones

Re: Blog settings for twitter plugin

Postby leeturner » Thu Sep 08, 2011 8:13 pm

EdB wrote:My view would be not until we have a useful online manua


I agree
leeturner
Dracone
User avatar
 
Posts: 730
Joined: Fri Dec 11, 2009 11:55 am
Location: Brighton, UK

Re: Blog settings for twitter plugin

Postby SusanG » Thu Sep 08, 2011 8:20 pm

EdB wrote:Well let's get one thing at a time. You installed the twitter plugin, it made a table, you went to your Tools->Twitter keys page and got your installation seen as an application by twitter, you copy/pasted the important bits back to your Tools->Twitter keys page. Must be good up to there because I'm pretty sure it won't let you connect a user to a twitter account if you don't.

So on your profile page you clicked the button for connecting twitter, it went to twitter and asked if you want to trust the application (which you created above), and you told it yeah sure, and it came back and showed you are connected to that account.

On your Blog settings->Plugin settings page you scrolled down and checked the box for "ping twitter"?


Yep! Though to be fair, I only found the last step today which is in GLOBAL SETTINGS / GENERAL for outbound PINGS. Setting it resulted in (a) pinging and (b) seeing the message that the tweets had gone out
say goodnight Gracie!
SusanG
Dracone
User avatar
 
Posts: 43
Joined: Sun Aug 28, 2011 9:35 pm
Location: Penzance, Cornwall

Re: Blog settings for twitter plugin

Postby EdB » Thu Sep 08, 2011 8:45 pm

Ah okay my bad. I thought that was a blog setting. Gonna have to make sure it kinda spells those steps out for people on the next release.
EdB
Dracone
User avatar
 
Posts: 2072
Joined: Sun Nov 22, 2009 7:20 am
Location: Maricopa Arizona

Re: Blog settings for twitter plugin

Postby SusanG » Thu Sep 08, 2011 9:20 pm

EdB wrote:Ah okay my bad. I thought that was a blog setting. Gonna have to make sure it kinda spells those steps out for people on the next release.


Not really. It is a Blog Setting too /Features/

If I understand the above thread, that is to enable syncing different twitter accounts with different blogs?
say goodnight Gracie!
SusanG
Dracone
User avatar
 
Posts: 43
Joined: Sun Aug 28, 2011 9:35 pm
Location: Penzance, Cornwall

Re: Blog settings for twitter plugin

Postby EdB » Thu Sep 08, 2011 10:56 pm

Correct, mostly.

The installation itself might have a twitter account. quamplures.net for example wants to tweet @quamplures
Each blog on an installation might have a twitter account. No active example of that for ya.
Each blogger might have a twitter account.

So at quamplures.net, if anyone posts it tweets to them and only them. The goal is to have it tweet for the author AND the installation. Adding a per-blog account connection is only because it should be. Adding "how many tweets in what order" is because the install owner might want to have some say in how it all works.

BTW default will be "every blogger and blog and the app can connect and we will send up to 3 tweets beginning with the blogger".

* gotta make sure I cover the steps to get it all operational too. I'm pretty sure I already added "this blog doesn't ping twitter" where you see "connected to @yourname" on the write page so that is kinda informative, but not in a directional sort of way.
EdB
Dracone
User avatar
 
Posts: 2072
Joined: Sun Nov 22, 2009 7:20 am
Location: Maricopa Arizona

Re: Blog settings for twitter plugin

Postby SusanG » Sat Sep 10, 2011 10:16 pm

I can't figure this out :|

I set up the twitter app, on QP it says it is linked to my twitter account. Publish, get all the nice ping notices, add'l ping and post to Twitter.

Go to my Twitter account and ... nada a damn thing :(

All the boxes are ticked AFAICS - both in Blog and Global!
say goodnight Gracie!
SusanG
Dracone
User avatar
 
Posts: 43
Joined: Sun Aug 28, 2011 9:35 pm
Location: Penzance, Cornwall

Re: Blog settings for twitter plugin

Postby EdB » Sat Sep 10, 2011 11:02 pm

PM me your login creds, please.

Actually that won't help none because you can see all that I could. Hey when you go to twitter and click your name in the top right and click on "applications" does your website show up there as a trusted app?

BTW the fileset I sent you does NOT contain the next gen twitter plugin. I'm still fighting it, but it is certainly tweeting to my user account. I am however curious if I somehow screwed up somewhere. Or if twitter got banged up by a branch and no one has noticed until now.

Another thing to check, please. Via cpanel check your your phpmyadmin and see that you have at least 2 of the 3 fields filled in for the twitter plugin table. The name should be something like qp_plugin_twitter_21_twitter but the number will be unique to you. Also in your qp_pluginusersettings table that you have 4 fields for the twitter plugin. The puset_plug_ID field will be your unique number, and one of the fields will be empty. The message_format field needs something so at the very least have $twitcerpt$ in there. The token and secret fields are important because that is part of the handshaking with twitter.
EdB
Dracone
User avatar
 
Posts: 2072
Joined: Sun Nov 22, 2009 7:20 am
Location: Maricopa Arizona

Re: Blog settings for twitter plugin

Postby SusanG » Sat Sep 10, 2011 11:26 pm

ok will do!

Edit twitter_msg_format $twitcerpt$
Edit Delete 19 1 twitter_secret xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Edit Delete 19 1 twitter_token xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx


twitter_contact is blank


Twitter Account - has the website url as having access to the app

Still looking for the qp_plugin_twitter stuff


Edit The access in the app in Twitter is Read Only. I still have access allowed from the b2 twitter plugin and that is Read and Write?
say goodnight Gracie!
SusanG
Dracone
User avatar
 
Posts: 43
Joined: Sun Aug 28, 2011 9:35 pm
Location: Penzance, Cornwall

Re: Blog settings for twitter plugin

Postby EdB » Sun Sep 11, 2011 6:46 am

The "read only" is the problem. It needs "read and write" else it can't write, which is what it is trying to do.

The next problem is you can't change that and I know I have problems with revoking permissions. Hate to say it, but the only thing I can be sure of is that you will want to delete the twitter plugin in your installation, then at twitter delete the app and revoke the permissions. The next part really sucks: via phpmyadmin delete the twitter-related bits in qp_pluginusersettings IF they remain after deleting the plugin. Once everything is set back to "this never happened" you can install the plugin again and re-do the "make me be an app" stuff, only this time hit the radio button for "read and write".

Off topic BTW in the next gen I'm trying like crazy to ALSO make it reasonably clear how to disconnect from twitter. The problem is both the installation and twitter need to know that is what a user/blog/installation wants to have happen without expecting people to go log in over there then come back here then stand on your head then spell ukulele backwards in Russian and so on and so forth. ONE click should do it eh? And therein lies the rub: nobody ever thinks of an app dropping itself out of the created connection so I have no one to steal ... er ... model from.


Anyway for now I would sledgehammer it even though it might work if you try a few other ways. Delete and drop and turn off and get everything back to "it never happened" then do it again.
EdB
Dracone
User avatar
 
Posts: 2072
Joined: Sun Nov 22, 2009 7:20 am
Location: Maricopa Arizona

Re: Blog settings for twitter plugin

Postby EdB » Sun Sep 11, 2011 6:52 am

Edit Hit http://dev.twitter.com/apps and it'll want you to log in or maybe it'll know you, but then you click the application's name, then the "settings" tab. Easy-breazy!


Not quite ... I did change the oauth setting but it didn't change the access level. To do that it is the Access Token that needs changing. And it seems that's going through some changes at Twitter https://dev.twitter.com/discussions/260

One thing, before I forget, when I installed the plugin and got your friendly instructions (I don't remember if they were in the TOOLS/TWITTER KEYS?) that I'm guessing were also supposed to directly create the app, it didn't. Twitter asked me to sign into the developer site and I created the app from Twitter direct (referring back to your template/notes)

It looks like I may have to revoke access in my account
Recreate the Access Token with the appropriate settings (if you read the thread linked above that may not work if Twitter is still changing how that works)
Come back into QP - Under TWITTER KEYS, there is a submit button that wipes out the keys?

At which point, I would then reauthenticate Twitter and QP?
EdB
Dracone
User avatar
 
Posts: 2072
Joined: Sun Nov 22, 2009 7:20 am
Location: Maricopa Arizona

PreviousNext

Return to Feature Requests

Who is online

Users browsing this forum: No registered users and 1 guest

cron