Page 1 of 1

Error on install

PostPosted: Mon Oct 07, 2013 9:58 pm
by Kimberly
OK, the guy reported back when he went to install the latest QP



> Installing Quam Plures ...
>
> Loading modules ... OK.
> Creating default groups ... OK.
> Creating default users ... OK.
> Creating default group/blog permissions ...
> *Notice*: Undefined variable: Group_Special in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *161*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *161*
>
> *Notice*: Undefined variable: Group_Special in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *162*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *162*
>
> *Notice*: Undefined variable: Group_Special in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *163*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *163*
>
> *Notice*: Undefined variable: Group_Special in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *164*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *164*
>
> *Notice*: Undefined variable: Group_Bloggers in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *165*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *165*
>
> *Notice*: Undefined variable: Group_Bloggers in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *166*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *166*
>
> *Notice*: Undefined variable: Group_Bloggers in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *167*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *167*
>
> *Notice*: Undefined variable: Group_Bloggers in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *168*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *168*
>
> *Notice*: Undefined variable: Group_Users in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *169*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *169*
>
> *Notice*: Undefined variable: Group_Users in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *170*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *170*
>
> *Notice*: Undefined variable: Group_Users in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *171*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *171*
>
> *Notice*: Undefined variable: Group_Users in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *172*
>
> *Notice*: Trying to get property of non-object in */home/oldmuscles/www/www/qblog/qp_install/_create_users.php* on line *172*
>
>
> An unexpected error has occurred!
>
> If this error persists, please report it to the administrator.
>
> Go back to home page <http://oldmuscles.com/qblog/>
>
>
> Additional information about this error:
>
> MySQL error!
>
> *You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 1, 'published,deprecated,protected,private,draft', 1, 1, 0, 0, 1, 1, 1 ), ( 2,' at line 18(Errno=1064)*
>
> Your query:
>
> INSERT INTO qp_blog_groups(
> bloggroup_blog_ID,
> bloggroup_group_ID,
> bloggroup_ismember,
> bloggroup_perm_poststatuses,
> bloggroup_perm_delpost,
> bloggroup_perm_comments,
> bloggroup_perm_cats,
> bloggroup_perm_properties,
> bloggroup_perm_media_upload,
> bloggroup_perm_media_browse,
> bloggroup_perm_media_change )
>
>
> VALUES
> ( 1, 1, 1, 'published,deprecated,protected,private,draft', 1, 1, 1, 1, 1, 1, 1 ),
> ( 2, 1, 1, 'published,deprecated,protected,private,draft', 1, 1, 1, 1, 1, 1, 1 ),
> ( 3, 1, 1, 'published,deprecated,protected,private,draft', 1, 1, 1, 1, 1, 1, 1 ),
> ( 4, 1, 1, 'published,deprecated,protected,private,draft', 1, 1, 1, 1, 1, 1, 1 ),
> ( 1, , 1, 'published,deprecated,protected,private,draft', 1, 1, 0, 0, 1, 1, 1 ),
> ( 2, , 1, 'published,deprecated,protected,private,draft', 1, 1, 0, 0, 1, 1, 1 ),
> ( 3, , 1, 'published,deprecated,protected,private,draft', 1, 1, 0, 0, 1, 1, 1 ),
> ( 4, , 1, 'published,deprecated,protected,private,draft', 1, 1, 0, 0, 1, 1, 1 ),
> ( 1, , 1, 'published,deprecated,protected,private,draft', 0, 0, 0, 0, 1, 1, 0 ),
> ( 2, , 1, 'published,deprecated,protected,private,draft', 0, 0, 0, 0, 1, 1, 0 ),
> ( 3, , 1, 'published,deprecated,protected,private,draft', 0, 0, 0, 0, 1, 1, 0 ),
> ( 4, , 1, 'published,deprecated,protected,private,draft', 0, 0, 0, 0, 1, 1, 0 ),
> ( 1, , 1, '', 0, 0, 0, 0, 0, 0, 0 ),
> ( 2, , 1, '', 0, 0, 0, 0, 0, 0, 0 ),
> ( 3, , 1, '', 0, 0, 0, 0, 0, 0, 0 ),
> ( 4, , 1, '', 0, 0, 0, 0, 0, 0, 0 )

Re: Error on install

PostPosted: Mon Oct 07, 2013 10:26 pm
by Kimberly
I get this on a new install as well. We just lost a user because of this.

Re: Error on install

PostPosted: Mon Oct 07, 2013 10:51 pm
by Kimberly
The problem lies if you select do not install sample content; the if must not be working probably in some way.

Re: Error on install

PostPosted: Tue Oct 08, 2013 1:59 am
by Kimberly
I guess these forums are dead. I don't really know where to look for the problem If I had not run into that problem with the database password containing a $ I would have seen this way back then because I don't install the demo content.

Re: Error on install

PostPosted: Tue Oct 08, 2013 5:05 am
by EdB
I wonder which version that was?

I'm spending full time driving a cab for very little income, but I'll try to figure out something about this issue. I hardly ever do an install without content ... but usually it is customized content. Anyway it shouldn't be a hard one to fix and will justify a release.

Oh and yeah it seems the forums are dead :(

Re: Error on install

PostPosted: Tue Oct 08, 2013 12:27 pm
by Kimberly
Yes, I know I have not been around but QP is always just in the back of my mind to get back here. The problem is that we all are struggling.

It is the current release that is from the big green button. I did have a look at the code but have never played with the installer so don't know the flow.

Re: Error on install

PostPosted: Wed Oct 09, 2013 2:36 am
by Kimberly
EdB wrote:I'm spending full time driving a cab for very little income,


So you are not driving the truck now?

Re: Error on install

PostPosted: Sat Oct 12, 2013 2:22 pm
by EdB
Haven't driven a truck in quite a while ... found and fixed this bug by the way. Now if only I can remember how to make branches happen .......

Re: Error on install

PostPosted: Sat Oct 12, 2013 2:41 pm
by EdB
okay the branch is now in merge ... it should, of course, be tested. I did a naked install of QP5 and had the same problem, solved it, then made the solution in a branch here. Assuming it works I'll update the big green button and try to figure out how to make other locations for downloading show the latest version