Support forums : Quickies

Upgrading jQuery

A home for really quick one-liner thoughts about what we need to fix or do or whatever. If they spark discussion we move it, otherwise this is like post-it notes.

Moderator: Dracones

Upgrading jQuery

Postby leeturner » Wed Aug 15, 2012 4:17 pm

I am still playing around with twitter bootstrap and creating a new admin look and feel and some of the bits I am playing with require a later version of jQuery than we currently have. Ed, I think you have said you upgraded things like jQuery in QP5 so I was wondering if you came across any problems upgrading?

I will probably go ahead and upgrade it in the branch I am working in with the aim being that we upgrade in the core at some point in the future.
leeturner
Dracone
User avatar
 
Posts: 730
Joined: Fri Dec 11, 2009 11:55 am
Location: Brighton, UK

Re: Upgrading jQuery

Postby EdB » Wed Aug 15, 2012 4:37 pm

what version do you need?

just checking what QP5 is on, remembered when I saw it you probably will want to upgrade jQueryUI as well. If memory serves me they kinda went hand-in-hand so I upgraded to a point where the two were nicely compatible with each other. My jQuery is at v1.6.2 and my jQueryUI is at v1.8.16. I don't recall any other problems than making sure they worked nicely together.

Upgrading TinyMCE will be difficult because there are evo-hacks in it that have to be migrated, and might even be some QP-hacks as well. OT but sorta related eh?
EdB
Dracone
User avatar
 
Posts: 2072
Joined: Sun Nov 22, 2009 7:20 am
Location: Maricopa Arizona

Re: Upgrading jQuery

Postby EdB » Wed Aug 15, 2012 4:41 pm

Looking at jQueryUI right now, I can't recall what bits I picked. Probably ALL then just deleted out everything that wasn't already there :)
EdB
Dracone
User avatar
 
Posts: 2072
Joined: Sun Nov 22, 2009 7:20 am
Location: Maricopa Arizona

Re: Upgrading jQuery

Postby leeturner » Wed Aug 15, 2012 4:44 pm

That's strange. The versions you have are actually the versions we have in QP so maybe I got that wrong and you didn't upgrade jQuery ???

I need at least jQuery 1.7.1 but I think it is at 1.8.0 now.
leeturner
Dracone
User avatar
 
Posts: 730
Joined: Fri Dec 11, 2009 11:55 am
Location: Brighton, UK

Re: Upgrading jQuery

Postby EdB » Wed Aug 15, 2012 4:47 pm

I did, but I probably didn't have QP5 back then :)

Same with TinyMCE - QP and QP5 are probably on the same versions with the same mods.
EdB
Dracone
User avatar
 
Posts: 2072
Joined: Sun Nov 22, 2009 7:20 am
Location: Maricopa Arizona

Re: Upgrading jQuery

Postby EdB » Wed Aug 15, 2012 4:48 pm

I'd say go for the latest and greatest ... assuming compatibility across jquery and jqueryui (which may not be an issue at all).
EdB
Dracone
User avatar
 
Posts: 2072
Joined: Sun Nov 22, 2009 7:20 am
Location: Maricopa Arizona

Re: Upgrading jQuery

Postby leeturner » Wed Aug 15, 2012 5:50 pm

I'll wait on this one for a while because I have just upgraded in my branch and it still didn't work :D

Must be something else making it not work.
leeturner
Dracone
User avatar
 
Posts: 730
Joined: Fri Dec 11, 2009 11:55 am
Location: Brighton, UK

Re: Upgrading jQuery

Postby leeturner » Wed Aug 15, 2012 8:31 pm

OK, I think I know why my new bit of code isn't working but upgrading to the latest and greatest really fucks things up for other areas of the admin. Most notably the widget screen and I also noticed the modal css box I implemented for the plugin help is also not working.

I have now upgraded to jquery 1.7.1 and that fixes the issues with the widget screen but not the modal dialog. I am going with 1.7.1 for now in my branch as that is what I need for the bootstrap bits and I don't have the time to look into why the widget screen is broken with the latest jquery. That would be a whole world of pain.

I'll test it a little more in my branch and see if I can fix the bits I notice not working and then perhaps think about replicating in the core later on.
leeturner
Dracone
User avatar
 
Posts: 730
Joined: Fri Dec 11, 2009 11:55 am
Location: Brighton, UK

Re: Upgrading jQuery

Postby Kimberly » Fri Aug 17, 2012 4:00 pm

EdB wrote:
Upgrading TinyMCE will be difficult because there are evo-hacks in it that have to be migrated, and might even be some QP-hacks as well. OT but sorta related eh?


Oh, that is not good to hear. TinyMCE is including support for HTML5 on a daily basis and is one of the reasons for upgrading.
Kimberly
Dracone
User avatar
 
Posts: 842
Joined: Mon Jul 19, 2010 4:44 pm


Return to Quickies

Who is online

Users browsing this forum: No registered users and 1 guest

cron